Author Topic: Cakewalk MIDI clips out of sync after import  (Read 1568 times)

Offline evaluna001

  • Newbie
  • *
  • Posts: 7
Cakewalk MIDI clips out of sync after import
« on: February 13, 2024, 12:20:29 PM »
Hi,
I recently discovered this impressive tool, and have been testing transferring some of my tracks to the trial version of Reaper with very good results, so firstly thanks for making this available.
I did notice that some MIDI clips which were looped (groove clips in Cakewalk) went out of sync after a couple of bars in Reaper. Not sure if this is a limitation of the conversion or another issue, but first bouncing the groove clips to a single MIDI clip in Cakewalk seems to resolve the issue. I am curious whether this is an issue for others, and that bouncing generally needs to be done prior to the import process? Thanks.

Offline azslow3

  • Administrator
  • Hero Member
  • *****
  • Posts: 1706
Re: Cakewalk MIDI clips out of sync after import
« Reply #1 on: February 13, 2024, 05:34:27 PM »
If you can send me example CWP, I can check from where the problem comes and may be fix.
At the time of development I have obviously checked that looped clips produce expected results, but it can be a bug from the beginning for some conditions or something is changed in CbB or REAPER.

Offline evaluna001

  • Newbie
  • *
  • Posts: 7
Re: Cakewalk MIDI clips out of sync after import
« Reply #2 on: February 14, 2024, 07:51:20 AM »
Thanks, I will send you the CWP file - much appreciated!

Offline evaluna001

  • Newbie
  • *
  • Posts: 7
Re: Cakewalk MIDI clips out of sync after import
« Reply #3 on: March 12, 2024, 02:40:53 PM »
Hi,
I tried to attach the file here, but the file type CWP is not allowed. I also could not see how to attach in a PM. I have copied it to Google Drive, please download it from the link below.

On my system after importing to Reaper, the drums go out of sync at bar 5, which is where the first loop point is. If I "flatten" the groove clips in Cakewalk first, then the sync is fine.

Please let me know if you have problems downloading the file, and I will upload it elsewhere.

Thanks, much appreciated.

https://drive.google.com/drive/folders/1nYcsSyUYueqyWWJzFBFlG0BuL1k9eNYV?usp=drive_link


« Last Edit: March 12, 2024, 02:46:52 PM by evaluna001 »

Offline azslow3

  • Administrator
  • Hero Member
  • *****
  • Posts: 1706
Re: Cakewalk MIDI clips out of sync after import
« Reply #4 on: March 13, 2024, 11:22:05 AM »
Hi,

Lets take all that into PMs. The link need confirmation... In general, it is better make read-only links to google drive allowed for everything, but send them by PM.
Button links here is forum can have side effects.


Offline evaluna001

  • Newbie
  • *
  • Posts: 7
Re: Cakewalk MIDI clips out of sync after import
« Reply #5 on: March 14, 2024, 03:07:28 PM »
Hi, Sent a new link by PM. Please let me know if you receive it, I cannot seem to access sent items to check. Thanks.

Offline azslow3

  • Administrator
  • Hero Member
  • *****
  • Posts: 1706
Re: Cakewalk MIDI clips out of sync after import
« Reply #6 on: March 14, 2024, 03:59:11 PM »
Yes, I have received it. Thanks!

Not only that, I in fact was in progress to decide what to do.
And now you can re-download ReaCWP (b62), for me it align your drums correctly (under Linux.. not checked in Windows  ;) )
So please confirm the problem is solved (or not), when converting on your computer.

Details:
while technically that was "a bug" in ReaCWP, logically it has uncovered yet another REAPER "imperfection". In REAPER, MIDI events
can't cross looping point (the last even defines the looping point, the one you could observe, and separate boundaries can not be specified).
For drums that does not matter (they trigger on "note on" and sound as long as specified by sampler). But f.e. for pads there can be
significant difference. Let say you have nice pad sound which should still sound when the next loop is already started. Cakewalk supports
that, "note off" can be later then looping time (and correctly delivered as such). REAPER force to trim MIDI clips exactly to the boundary,
so such "left over" is not possible.

In practice, if you have projects with sustained sounds from looped MIDI clips and they don't sound "right" after conversion, bounce them before converting.

PS. Cakewalk saves looped MIDI as not looped, so repeating everything for the whole clip length... So I could ignore looping during conversion.
But I have decided that is not what people see in Cakewalk, and so I convert as people expect it to see in REAPER. Well, that has consequences.

 

Offline evaluna001

  • Newbie
  • *
  • Posts: 7
Re: Cakewalk MIDI clips out of sync after import
« Reply #7 on: March 15, 2024, 08:14:31 AM »
Thank you so much for looking at this, I really appreciate it! It is interesting how different DAWs respond to similar situations.
I will update and re-import that file into Reaper this weekend and let you know how it goes in Windows! Thank you again.

Offline evaluna001

  • Newbie
  • *
  • Posts: 7
Re: Cakewalk MIDI clips out of sync after import
« Reply #8 on: March 15, 2024, 09:45:26 AM »
Hi, I am sending this message here so I can attach screen shots - the sync problem is still there on Windows, plus a new problem. That same file I uploaded previously included a bass pattern on track 18 in Reaper, but importing it using the new DLL brings in no MIDI at all for track 18, so the bass is gone. But the original sync problem is still there on Windows, I am attaching 2 screen shots to illustrate, one shows where the loop points are in Cakewalk, and the other shows the same file in Reaper but the loop points in Reaper are not in sync. Hopefully this is something you can re-create in Linux and is not a unique problem to Windows! Thanks.

Offline azslow3

  • Administrator
  • Hero Member
  • *****
  • Posts: 1706
Re: Cakewalk MIDI clips out of sync after import
« Reply #9 on: March 15, 2024, 04:39:53 PM »
The "fix" had a bug... sorry. I had just one track on the screen and was happy it works correctly. Obviously all other tracks was bugged.

I have uploaded b63, with fix for the fix  ;)

Offline evaluna001

  • Newbie
  • *
  • Posts: 7
Re: Cakewalk MIDI clips out of sync after import
« Reply #10 on: March 19, 2024, 10:19:13 AM »
Hi again,
Thanks for the fix to the fix  :D
I have imported that test file and it comes through perfectly in sync, and the bass track MIDI is also there now. Thanks again for looking at this so quickly. I will be importing more tracks over the next few days, hopefully I will have nothing to report back!