Author Topic: I had Launchkey 49 + AZCont working before but am having a serious brain fart  (Read 526 times)

Offline truemetalgeek

  • Newbie
  • *
  • Posts: 4
So... It's been a while since I installed and setup Sonar with my Novation Launchkey 49 MKII however recently my PC I had this old gear connected to died and I decided to set it up on a laptop instead in my hobby room.

I previously used a PC with a creative labs EMU running in ASIO all that stuff but to my surprise the Sonar is actually working with the basic laptop and laptop USB C dock's audio so I figured I would set up the Launchkey.

So far the Launchkey is working to play sounds with midi instruments but I can not for the life of me get it to run the transport controls.
I was previously able to work the sliders and play/stop/rewind with the Launchkey on the old PC setup but not now.
As shown in the screenshot, I had used the AZCONTROL along with the Launchkey61 plug in back in 2017.
I did get the updated version of azcontrol today as well.

So I do have it installed.
I set up the inputs for the LAUNCHKEY.
I used the plugin tool to add the preset.
And I can see the commands in the AZ Control utility when I move a knob or press a button.
I just can't get it to work the transport control.

And all that said... perhaps I am missing something in the instructions and am not doing one stupid thing that it takes to make it work. LOL

Oh, I did install the latest Sonar from BandLab so that would be newer/different than whatever version I installed some years ago.

Any tips guys?

Attached are some screenshots.
I do see that the AZ Control utility shows something about it mapped to session drummer. So that can be a clue. Maybe something needs to be changed?

Thanks,

Offline azslow3

  • Administrator
  • Hero Member
  • *****
  • Posts: 1573
Launchkey has 2 MIDI port sets. One for "normal" MIDI (keys, knobs/faders as MIDI controls for VSTi) and another "In Control", for DAW operations. Check you have enabled the second set (in Cakewalk MIDI devices section) and and assign it to AZ Controller. Not sure the name of the ports mention "In Control", can be there are named like "MIDI input 1" and "MIDI input 2".

After changing ports, reload the preset (it tries to activate "In Control" mode on load).

If that does not help, I will write more detailed proposal how to troubleshoot.

Offline truemetalgeek

  • Newbie
  • *
  • Posts: 4
Thanks for the reply.

See attached photos.
The device does indeed show up as two inputs.
One is named Launchkey and the other is MIDI IN2

They are enabled. When I turn the knob I see the last valve shown there in the AZ Control utility there.

And when I press a button or move a knob I get some action in the MIDI track there.
But maybe as you suggested it is not sending the control data but other MIDI?

I am not sure where I assign something TO the AZ Control.
Unless that is in the Control Surfaces section of the preferences. There I do have the option for the Launchkey or the MidiInb2. Which I've tried each.

It doesn't help that every few years when I decide to tinker with recording that Sonar is changed and the menu layout changes. LOL
« Last Edit: July 29, 2022, 05:22:14 PM by truemetalgeek »

Offline truemetalgeek

  • Newbie
  • *
  • Posts: 4
I noticed that the MASTER slider does work to change the volume for the session drummer when I manually play some drum sounds to it.
So it seems that somewhere the commands are going to that rather than to control the main board or whatever you call it.
I see in the AZ Control utility it shows ACT MAP to Session Drummer.


I have no idea where that gets changed.

Offline truemetalgeek

  • Newbie
  • *
  • Posts: 4
I think I got it.
I noticed that whichever plug in item I clicked on, Cakewalk TTS or the Session Drummer, it showed that as the ACT MAP in the AZ Control utility. SO I guess that meant nothing.
But as I was poking around I clicked on the preset name on top, on accident, and then stuff lit up on the Lauunchkey and the controls started working.

Weird. I did try to load the preset several times. Not sure what I missed before.  :-\

Offline azslow3

  • Administrator
  • Hero Member
  • *****
  • Posts: 1573
MIDIIN2 and MIDIOUT2 should be assigned to AZ Controller and then preset reloaded (or Cakewalk restarted). AZ Controller tells the keyboard "I am there and I know who you are", keyboard switch itself into proper mode and everything should work as desired.

Cakewalk supports several ways to control plug-ins (synths and effects). One of them is "ACT dynamic mapping", "ACT map" displays current plug-in which that approach targets. But that is not the only way. Also Launchkey supports different ways. All that can be a bit confusing at first.