Author Topic: Piano synth under Linux  (Read 5281 times)

Offline azslow3

  • Administrator
  • Hero Member
  • *****
  • Posts: 1596
Piano synth under Linux
« on: October 18, 2016, 11:24:47 AM »
When on shift, my notebook should continuously run monitoring components and other software, all that under Linux. And so I can not just reboot into Windows... I have also found that taking full scale Digital Piano and using it late nights in a hotel does not work well. At the same time, 49 keys Roland MIDI board is small, close to silent, and while keys are not full size (in length) for my n00b taste I can play piano with it. J.S. Bach (and some other composers at that time) also had 49 keys for a while, so there is some suitable piano music.

Several times I was about ordering Pianoteq since it has Linux stand-alone version. But every time I "demo" it, I find myself not ready to spend the money for THAT sound. I have tried several modules and I have tried to tune the settings. But no matter what I do, my body say me "that is not a piano...". I have not played the instruments it tries to emulate, but I can not imagine they all are so "lifeless". I have the same feeling from Roland Supernatural (read "completely synthetic") pianos. Many people, much more experienced then me, claim that both are "deep and realistic". So my opinion is probably subjective, driven by the fact that all (acoustic) instruments I have played was either old (100 years +) without full "upgrade" or quite bad from the factory. I mean I was always playing not perfect instruments and all of them had strong "life" characters, which my brain expects from piano synth as well.

Yesterday that has happened again, I have started to play Panoteq 5 demo with intention to order it, but the sound... And then I have remembered that I have full version of TruePiano which I took on sale and with additional Cakewalk discount. I know most people will say it is "aged and not updated for years". So what? If I can play Bechstein which "was not upgraded" last 100 years, what the problem is with something not upgraded last 3-4 years?

Ubuntu + jack (+ qjackctrl) + Festige + TruePianos (installed usual way under Wine) = the sound I can enjoy.

The installation more or less strait forward for everything, but 3 tips:
* follow in case jack installation has not done that for you. To check that you need it, run "ulimit -r". If you get "0", you should tweak the settings manually. Also in the qjackctrl log you will see some warnings about memory locking and setting priority in case settings are incorrect.
* if qjackctrl log shows that ALSA device could not be contacted, open options and specify hardware devices explicitly.
* it can happened that pulseaudio (default Ubuntu audio system) will no longer work afterwards. You can "cooperate" jack with pulse (there are several descriptions what can be wrong there and how to fix that) or "killall pulseaudio" (it will be auto-restarted) after using jack.

I am getting ~15ms latency without any tuning and only rare small jitters on my very old Centrino based notebook with build-in Realteck audio. Note that my system/ram/(wireless)networks is under significant load from not music related activity activity. Unfortunately I have not managed convince Sonar X2 to operate under 200ms latency there, but there are still some settings not tried...