Author Topic: Several plug-ins for one Surface  (Read 3850 times)

Offline azslow3

  • Administrator
  • Hero Member
  • *****
  • Posts: 1578
Several plug-ins for one Surface
« on: July 30, 2014, 04:09:14 PM »
Since ACT MIDI has fixed number of controls and Generic Surface can not control buses and has other limitations, you can come to the idea (sometimes mentioned in the official forum) to use several plug-ins with the save device as input. Yes, you can. But there are several facts you should know in case you do:

The same plug-in instances can be not completely separated
I have not tested that intensively, but I have seen that in practice. There are some reports in the official forum with more details, at least for ACT MIDI. In practice, that means in case you have 2 instances of ACT MIDI you can expect at least following glitches:
  • When working with preset, keep open only one user interface. For example, in case you have 2 ACT MIDI opened, loading preset in the second one will load it into the first instance instead
  • If you save preset in one of it, the name of preset in another also changes. Be careful with that, not to overwrite presets incorrectly. Note, that after SONAR restart the indication can again be wrong and you can be forced to reload presets for each instance
  • ACT mode works only in second instance. The first one indicates it is switched, but it does not really switch into it.

MIDI messages "leaks"
That is hard to explain without going deep into MIDI standards, so just by example.
Let say you assign some button sending Note (C4)  (can be rotor sending CC, and so on) to the button 4 (ACT Enable) in  ACT MIDI. If that is the only plug-in connected to your surface, after that assignment C4 will switch ACT mode but it is no longer sent as Note C4 to your track. In case you insert yet another plug-in and connect the same surface to it and not assign Note C4 there, this button while still switching ACT mode will be sent to your track. You can check that using any synth.

Why that happens? Once C4 is received, SONAR send it to the first ACT MIDI. It interpret it, switch ACT mode and indicate it should not be sent to the track. But then SONAR send the same C4 to the second plug-in (since it is configured with the same input surface). That second plug-in does not "intercept" that note, so SONAR send it to the track (ignoring the "veto" from the first plug-in). I think it is a bug.

Please note, that I have tested that with X2 only. In can be different with X3.

In case you add AZC as the last plug-in for the device and set "Block all midi channels" in the "Options" tab (no other settings required), AZC will block all channel MIDI messages from the device, effectively eliminating the problem.
« Last Edit: January 14, 2015, 03:04:29 PM by azslow3 »