Author Topic: [AZ, Watercourse, BobF] PreSonus Faderport  (Read 32467 times)

Offline azslow3

  • Administrator
  • Hero Member
  • *****
  • Posts: 1197
[AZ, Watercourse, BobF] PreSonus Faderport
« on: April 14, 2015, 11:46:43 AM »
Produced in cooperation with Watercourse.

The preset is included into release version

Preset should work out of the box.

How to use it:
  • Install AZ Controller plug-in first (download the latest released version mentioned in the News section).
  • Configure Faderport MIDI Input/Output in SONAR as described in its documentation. But do not proceed with the original Faderport plug-in
  • Insert AZ Controller in the "Control Surfaces" section of SONAR preferences and attach Faderport MIDI Input/Output to it. It is good idea to detach it from other plug-ins, in case you have already used it with sonar.
  • Open AZ Controller configuration dialog
  • Switch to the "Options" Tab and in the "Tweak current configuration..." drop box select "Faderport".
  • Press "Create preset"
  • In the preset name box (on top of the window) type "Faderport" and press "Save" button. Select just saved preset to reload it (that should setup WAI correctly)


The preset defines at the moment:
  • The fader control current Track/Bus Volume
  • Pan encoder control current Track/Bus Pan (Mix Bank) or "ACT Speed Dial" (ACT bank). When Bank is pressed, the value is changed in Hi resolution mode, Low resolution otherwise. With Shift - Beat Jogger, with Loop - Zoom Horizontal
  • Mute/Solo/Record arm current Track/Bus
  • Left/Right move focus to the previous/next strip
  • Bank - when used alone, switch between Mix and ACT Banks. Modification key otherwise (currently modify Pan encoder only, see its description)
  • Output switch between Track and Bus (light on Bus). WAI indication follows the selection
  • Read/Write - enable/disable read/write automation for current strip Volume and Pan
  • Touch - snapshot current strip volume, lights when the Fader is touched
  • Off - switch motor operations off (light when motor is disabled)
  • Mix/Proj/Trns - show console/show ProChannel/Show or hide Multidock
  • Undo (Shift:Redo) - Edit | Undo/Redo
  • Shift - when pressed during other control engagement, change it operation (see other controls description). When pressed alone, latch/unlatch Shift mode
  • Punch - toggle autopanch mode, with Shift - GoTo previous Marker. Light when Autopunch is on.
  • User - nothing, with Shift - GoTo next Marker
  • Loop - when used alone toggle loop mode (forcing loop region to selection), mod. key for some controls (see other controls description). With Shift - set Marker. Light when Loop mode is on.
  • Rewind - start Rewind (stopped when the button is released), with Loop - Set Loop Start, with Stop - RTZ, with Shift - GoTo Loop Start
  • Fast Forward - start Fast Forward (stopped when the button is released), with Loop - Set Loop End, with Shift - GoTo Loop End
  • Stop/Play/Record  - corresponding transport functions

Changelog:
2.11.2016 - starting from v0.5r3b343, generated preset includes initialization (you will need to regenerate the preset, all your own custom changes will be reset by that action!)
« Last Edit: November 02, 2016, 06:58:44 PM by azslow3 »

Offline azslow3

  • Administrator
  • Hero Member
  • *****
  • Posts: 1197
Re: [AZ, Watercourse] PreSonus Faderport
« Reply #1 on: April 14, 2015, 09:25:12 PM »
.

Offline azslow3

  • Administrator
  • Hero Member
  • *****
  • Posts: 1197
Re: [AZ, Watercourse] PreSonus Faderport
« Reply #2 on: April 14, 2015, 09:25:21 PM »
.

Offline watercourse

  • Newbie
  • *
  • Posts: 19
Re: [AZ, Watercourse] PreSonus Faderport
« Reply #3 on: April 14, 2015, 10:34:35 PM »
Very encouraging first test.  I noticed that the Faderport WAI is already following the Sonar selected bus, which was the whole reason for this venture :).  Details below:

1) Mapping of button functions looks to be correct so far, except for the lights. See #3 below.
 
2) All transport buttons are working properly.
 
3) Lights are working but mis-assigned.  Rundown as follows:
  Mute->lights up channel select R
  Solo->lights up Output (channel/bus button)
  Arm->lights up fader 'Off' button
  Output->lights up solo button
  Fader 'Off' ->lights up Arm button
  Shift->lights up transport stop button
  Rewind->lights up transport FastFwd
  FastFwd->lights up transport Rewind
  Stop->lights up shift (default state on load)
  Play->lights up 'Punch' button
  'Loop' button light is triggered by the first touch of the volume fader and remains lit until Sonar is closed and restarted

4) Pan is working perfectly.  There is no LED ring on the surface for the encoder.
 
5) Fader behavior:
  -motor moves all the way to the top of its path (6.0) on any track with a volume of more than '-INF' and all the way to the bottom of its path on a track with '-INF' volumne
  -after one track's volume is adjusted from the surface, the fader motor seems to stop responding altogether and will not work again until Sonar is closed and restarted
  -The fader does work to adjust track volume, but only when the current track's volume is 'met' by the physical fader. I'm guessing this would be resolved when the motor responds properly to the current track volume position.

Offline azslow3

  • Administrator
  • Hero Member
  • *****
  • Posts: 1197
Re: [AZ, Watercourse] PreSonus Faderport
« Reply #4 on: April 14, 2015, 11:37:45 PM »
Thank you for detailed report!

I more or less understand possible reasons for these problems. Too many never tested features can not work out of the box  :)
I will check/fix everything tomorrow and let you know.

Offline azslow3

  • Administrator
  • Hero Member
  • *****
  • Posts: 1197
Re: [AZ, Watercourse] PreSonus Faderport
« Reply #5 on: April 15, 2015, 10:50:57 AM »
I have updated the test version. Please redownload it.

"Fader Touch" never turns off was a bug in my configuration. I hope it is fixed now.

3) Lights are working but mis-assigned.  Rundown as follows:
Either something is horribly wrong in my MIDI engine, or Faderport MIDI mapping was done Monday morning...
Please check either it is correct now. If still not, I will try to dig what is wrong in my code. If it works...  lol.

Quote

5) Fader behavior:
We have to find out what this fader wants from us

Select "Logic" Tab. Select "Fader test" Logic Control (the first one in the list).
Select each action and press "Play". Notice what fader is doing. I hope some of these actions manage to move it to some intermediate positions.
Notice what position it is in (1/4, 1/3, etc. I do not need mm).

You see 3 blocks of actions (CC14:0, CC:0 and CC:32). If you find that in some block(s) it moves 0, 1/4, 1/2, 3/4, 1, the job is done.
Otherwise we have to find "max" for the fader. Select some action from the block which somehow works (so you get not only 0 and 1),
and start changing "Value" parameter. Every time press "Play" to apply. Try to find "the middle" value.

Quote
  -The fader does work to adjust track volume, but only when the current track's volume is 'met' by the physical fader. I'm guessing this would be resolved when the motor responds properly to the current track volume position.
That is expected. The fader is in "Catch" mode. It is possible to disable Motor ("Off" key), and this mode is logically the best to avoid "jumps". There are other modes we can try then, but lets get basic setup working first.

Offline watercourse

  • Newbie
  • *
  • Posts: 19
Re: [AZ, Watercourse] PreSonus Faderport
« Reply #6 on: April 15, 2015, 10:14:12 PM »
Thanks for the updated test version.  Results from b177M below:

Quote
"Fader Touch" never turns off was a bug in my configuration. I hope it is fixed now.

-The 'touched' bug is fixed. 
-Lights are still behaving the same (working but same incorrect mappings as before).

Quote
You see 3 blocks of actions (CC14:0, CC:0 and CC:32). If you find that in some block(s) it moves 0, 1/4, 1/2, 3/4, 1, the job is done.

CC14:0 Value:3fff - fader goes all the way up
CC14:0 Value:0 - fader goes all the way down
CC32:0 Value:3f80 - fader goes 1/8 up when starting from bottom

Offline azslow3

  • Administrator
  • Hero Member
  • *****
  • Posts: 1197
Re: [AZ, Watercourse] PreSonus Faderport
« Reply #7 on: April 15, 2015, 10:49:48 PM »
-Lights are still behaving the same (working but same incorrect mappings as before).
Agrrr... please redownload, I forgot to change one number ;)
(but Transport keys had to be different...)

Quote
CC14:0 Value:3fff - fader goes all the way up
CC14:0 Value:0 - fader goes all the way down
CC32:0 Value:3f80 - fader goes 1/8 up when starting from bottom
Please try to find some CC14:0 values which produce intermediate position. Start with "0" "127" (I hope that should produce the same result as CC32:0 3f80). And then change "0" to "1", "2", "10".

It looks like it has different scaling as input (and assuming LED order, that is not going to be a surprise for me).
But I still hope that CC14:0 is the way to go (1/8 from CC:32 , please notice the difference, it is not CC32:0 (not existing 32bit MIDI CC number 0, but "normal" 7 bit CC number 32. CC14:0 is 14bit CC (send with 2 MIDI 7bit CC) number 0).

EDIT: may be CC14:0 with values "3" "127" is the middle... But have you tested that moving the fader covers the whole range in SONAR?
« Last Edit: April 15, 2015, 10:58:17 PM by azslow3 »

Offline azslow3

  • Administrator
  • Hero Member
  • *****
  • Posts: 1197
Re: [AZ, Watercourse] PreSonus Faderport
« Reply #8 on: April 15, 2015, 11:00:39 PM »
And since you are here, check that the version is 179M. I have uploaded it right now, after finishing the replay...

Offline watercourse

  • Newbie
  • *
  • Posts: 19
Re: [AZ, Watercourse] PreSonus Faderport
« Reply #9 on: April 16, 2015, 02:45:14 AM »
Ok, lights look good.  Fader still has same behavior as before, although I'm guessing you haven't addressed that yet.

Offline azslow3

  • Administrator
  • Hero Member
  • *****
  • Posts: 1197
Re: [AZ, Watercourse] PreSonus Faderport
« Reply #10 on: April 16, 2015, 11:36:09 AM »
Ok, lights look good.  Fader still has same behavior as before, although I'm guessing you haven't addressed that yet.
I can not fix the fader till you find what it is expecting. You have provided complete map for LED, so I could find the algorithm (to light LED on some button with KP X, I have to send KP (X&0x78)+(7-X&0x7). It is already clear that Faderport expect feedback in not the same format as it send it.

So, till we find out what it expect for the fader, we can not fix it. And only you can test. As I wrote, CC14:0 "3" "127" (so, "value 1ff" as displayed in the action list) is my guess for the middle position. But that is a guess only.

Offline azslow3

  • Administrator
  • Hero Member
  • *****
  • Posts: 1197
Re: [AZ, Watercourse] PreSonus Faderport
« Reply #11 on: April 16, 2015, 04:59:32 PM »
I have uploaded b181.

I have applied my guessed logic for the Fader, so with some luck it should work out of the box. If not, please find the value to use...

Since buttons and encoders are working fine, to accelerate final preset development I have started to implement additional function. See the first post what should work.

I have followed Faderport user manual. Unfortunately, there is no Sonar specific section which describes all operations. And some functionality is unclear for me. But as you can see I have added one "extra" function, Shift+Pan should work as a jogger. I have not applied "Bank+Arrows" since I do not see the reason for it (for significant distance movement, mouse is faster).

Please let me know what dos not work and which functionality you are missing. That can be "orginal" behavior or something else. Any key can be used as modifier, not only Shift. For example, it is possible to define "Loop+<<", "Shift+Loop+<<" and so on. For the encoder or fader we can also apply "ACT Speed Dial" (we need some button/LED to switch the mode, "User" for example). We can control ProChannel EQ (Freq/Gain on Pan/Fader, Channel Select buttons as Band On/Off, Fader Mode as the band selector with indication), or ACT in general (using the same concept, current parameters can be shown on internal display). That are just some possibilities from the (endless) list.

Project/user specific functions (GoTo named marker, select strip by name, etc) can be done by users. So we can leave some button (combinations) unassigned.

Offline watercourse

  • Newbie
  • *
  • Posts: 19
Re: [AZ, Watercourse] PreSonus Faderport
« Reply #12 on: April 16, 2015, 07:11:40 PM »
First off, sorry I skipped over the fader section in your last reply--that was my bad.  Secondly,

YOU ARE AWESOME!

I liked the Faderport to begin with, but now I feel like it will be as good as I imagined it could be.  Some feedback before I continue gushing:

-fader tracks perfectly (in my initial tests)
-only issue so far is that the pan isn't recording automation
-The Shift/Pan as a jogger is a beautiful touch

One thought I've had is to incorporate a Sonar Shift+b into the 'Output' select so that it opens and closes the bus window when Faderport moves between track/bus selections--don't know if other users would like that but I would find it helpful.  And, if possible, to have Sonar actually shift from track focus to bus focus when 'Output' is clicked.  I think you mentioned that may not be reliable (buggy in Sonar?) but I thought I'd mention it to get your thoughts.

I found the Faderport's initial use of the "extra" buttons pretty weak and not very useful anyway, at least for my purposes.  I'm actually going to need some time playing around with it to explore the new possibilities and figure out what would work best either for my use, or at least the average Sonar user.  I'm thinking 'Bank' might be really useful as a 2nd shift operator for different functions. I'll let you know what I come up with.

I know there's still more to do but I just can't thank you enough for your time and effort.  You're turning a slightly above-average device into a home run!

Offline azslow3

  • Administrator
  • Hero Member
  • *****
  • Posts: 1197
Re: [AZ, Watercourse] PreSonus Faderport
« Reply #13 on: April 16, 2015, 07:39:54 PM »
YOU ARE AWESOME!
Thanks!

Quote
-only issue so far is that the pan isn't recording automation
What you mean by that? At the moment, "Write" button turn automation write for the fader only. I can turn it on/off for Pan as well (so, it will toggle it for Pan and volume simultaneously). Is that what you mean?

Quote
One thought I've had is to incorporate a Sonar Shift+b into the 'Output' select so that it opens and closes the bus window when Faderport moves between track/bus selections--don't know if other users would like that but I would find it helpful.
I will include it as configurable option on preset generation (where you press "Create preset"). We can put other specific behavior here as well.

Quote
And, if possible, to have Sonar actually shift from track focus to bus focus when 'Output' is clicked.  I think you mentioned that may not be reliable (buggy in Sonar?) but I thought I'd mention it to get your thoughts.
Will add it.

Quote
I know there's still more to do but I just can't thank you enough for your time and effort.  You're turning a slightly above-average device into a home run!
"You can integrate your Control Surface with SONAR as deep as you want!" was my promise  ;)

Offline watercourse

  • Newbie
  • *
  • Posts: 19
Re: [AZ, Watercourse] PreSonus Faderport
« Reply #14 on: April 16, 2015, 09:37:25 PM »
Quote
What you mean by that? At the moment, "Write" button turn automation write for the fader only. I can turn it on/off for Pan as well (so, it will toggle it for Pan and volume simultaneously). Is that what you mean?

That's correct.  The default behavior for the Faderport is that the 'write' button turns on/off write mode for volume and pan simultaneously.  I found that convenient but don't have much experience with hardware automation so I don't know if there's a downside to configuring it that way.

Looking forward to the next round.